Double quotes and you ...

Useful items for all visitors - virus warnings, firewalls, IRC scripts etc

Moderators: Ehlanna, Twerlinger

Double quotes and you ...

Postby Ehlanna on Fri Jun 08, 2018 3:15 am

I have seen this more and more of late, and as it can affect your ability to use some commands with Desdaemona I thought I'd just bring it up ..

The double quote character (") often found 'above the 2 key', so using Shift-2 to access it is the character that Desdaemona requires at the start and end of a bit of text that she needs to be able to consider to be one thing, such as a character name with a space in it. With smart phones becoming more used, and with some laptop keyboards and maybe even with some Operating Systems on computers, there seems to be a drift away from using the proper character, instead a smart quote is used.
You may have seen those when using products such as Word, the program will 'smartly' swap your double quotes for you to a start and end quote character (also, swapping ... (that is 3 full-stops/period) in a row into a single ellipsis character).

In the !mail send command you need to put proper quotes around the character name and in the !shopitem give command you need to likewise quote the name of the item if it has spaces in it. The question now becomes, how do I do this?

It will depend on what you are using! Sadly (actually, happily!) I do not use a lot of different kit, so am out in the cold on this. If you think you are having issues, try a simple test as one of out players recently did:

[23:41] <+Brixbon> !choice “coolest and the strongest” coolest strongest
[23:41] <@Desdaemona> I choose "strongest" from the 6 options supplied by Brixbon
[23:41] <@Ehlanna> See?
[23:41] <+Brixbon> sure enough six options

They may look like quotes in here, but on IRC most people see them as black squares.

To get a quote on a PC running Windows, you can, whilst holding down the Alt key press 0034 (that is press, and hold the Alt key, then zero, zero, three, and finally four, then release the Alt key). You can also use the On Screen Keyboard (if available) - go to Start> Run and type osk
If using a smart phone there may be an option to turn off smart correct and that may work for you.

I am reliably informed that to get a proper quote from a MAC, if you are having issues, is to use Ctrl-Shift-' (where the ' symbol is the key that shows a ' and " to the right of the keyboard next to the key that has the colon and semi-colon on) - thanks to Irelynn for this info

Good luck! :)
High Council
High Council
Posts: 2073
Joined: Sat Apr 09, 2005 9:23 pm

Re: Double quotes and you ...

Postby Lindor on Wed Jul 11, 2018 5:39 am

Been having a heck of a time with this lately, myself, as I’m almost exclusively on either iPhone or iPad these days.

I have discovered that if you press and hold the apostrophe key on on the device’s on-screen keypad, you will get a number of options to select from

‘ " “ ” „ « »

The one that Des likes looks like this: "

I have not yet figured out how to access this feature with the Smart Keyboard when it is attached to the iPad.

Not sure about other smartphone or tablet types, but I hope this helps the Apple fans out there.
User avatar
Posts: 225
Joined: Sat Jul 19, 2008 2:07 am
Location: The Open Sea! And sometimes Nanthalion...

Return to Public Service

Who is online

Users browsing this forum: No registered users and 1 guest